
Tips & Tools for 3D Designer

 

●     Creating Outfit Files
●     Creating Decorations and Carpets
●     The moovePack Tool
●     Converting "old" actors
●     Differences between the old rose actors 
and the actors of the new generation

●     Creating Styles
●     Creating Screenshots

 



Tutorial for Creating Outfit Files
The Actor Studio needs outfit files for creating and exchanging body parts, pieces of 
clothing, faces, etc.
The big advantage of this technology: The outfit files are transmitted automatically - this 
means no "red robots" anymore! The other users will see the outfit, but they won't be able 
to use it themselves. This transfer is optimized for broadband users (e.g. DSL), and may 
therefore take longer with slower connections. You can also offer the file for download and 
give permission of "wearing" your self-made outfit, meaning there will be no need for the 
automatic transfer.
Offering the file for download: The outfit file is already pre-packed; nevertheless it is 
recommended to process it with the moovepack tool into a mpz.file. This will enable the 
outfit to be downloaded automatically: it will be immediately available for use in the Actor 
Studio. You can download  the moovepack.exe in the shop. Please contact 
support@moove.com if you wish to use the digital signature feature to sign your work. In 

this case we need a personal ID (e.g. a copy of your driver's licence, etc. 
For the creation of your own outfits, you need resources like 3D objects and textures. 
These can be created with standard tools. Of course it's easier if you use already existing 
moove SRF and JPG files. You can find these in the respective moove/SRF or moove/Art 
folders.
We already put together packages with all the files and tools you need for creating outfit 
files. You can find these packages in the "moove Shop" -> "Developers".

This tutorial will show you how to create your own outfit files for the Actor Studio. As an 
example we will use a baseball cap; this example outfit consists of a single part 
('subpart'). Of course there are more complicated outfits (e.g. shirts) consisting of more 
parts, but these will all follow the same principles.
To create an outfit file, you need several different files (Assembly Text [ASM file], base 
texture, 3D file, and mmg.exe).

●     The Assembly Text  (ASM File)

●     The MMG File

●     Creating an MMG

●     The Outfit File

 

http://web.moove.com/help_advanced/outfit_tutorial/outfit.htm


The Assembly Text (ASM File)

This file gives a detailed description of an outfit's properties.

Every part is defined in its size, where it is connected to the body and how it is 
animated. The ASM also includes information on the graphical representation: 3D 
surface, painting and additional commands for even finer settings.

There are different possibilities to paint a 3D object:

1. You can paint it with a base color (in red, green, blue = 'RGB') or a texture (JPG file). 
However, in this case, you will not be able to change the color of the part in the Actor 
Studio later on. 

2. Use of an MMG file. If you use an MMG file, you can paint the outfit in the Actor Studio 
and make it transparent. The advantage of this technique is that you don't need to 
create a new outfit for every change in color you want to make. 

Here are the properties of our baseball cap (to the left using an MMG file - to the right 
using a texture). You can edit all the settings highlighted in red. 

 



Explanation with use of an MMG file:
Level 500
Defines the order of the clothing, i.e. a 
pair of socks can't be worn over a pair of 
boots. Here you can find an overview of 

the different levels. 

MAXCOL 5
Defines the number of areas that can 
later be colored in the Actor Studio. In 
this example five areas are colorable. 
DIM 16.36 12.62. 26.21
Defines width, height and depth of the 
part.
ORIGIN 8.19 -6.34 7.43
Defines the pivot of the respective part.
NONBBOX
Defines that the part cannot collide with 
other parts.
FROM Head 0.0.0
Defines the space and connection 
between ORIGIN of a parent and child 
part.
AXES X Y Z
Defines 3 axes of rotation. With a minus 
sign in front of the axis you can define 
the rotating direction (clockwise or 
counterclockwise)
RANGE 260,0 360,0 360,0
Defines limits for rotation of joints.
JOINT Hat
Defines name of the joint.
SRF bassb_cap
Defines the 3D object that will be used 
(SRF file).
PAINT 128,128 rgb 0,0,0
ADD bassb_cap
Uses an MMG file (here 
'bassb_cap.mmg') that allows you to 
color or make transparent individual 
areas of the object. If you are using an 
MMG file, you need to add the name of 
the MMG file but not the extension 
*.mmg.
 

Explanation for a subpart with a 
base texture only:
Level 500
Defines the order of the clothing, i.e. a 
pair of socks can't be worn over a pair of 
boots. Here you can find an overview of 

the different levels. 

MAXCOL 5
Defines the number of areas that can 
later be colored in the Actor Studio. In 
this example five areas are colorable. 
DIM 16.36 12.62. 26.21
Defines width, height and depth of the 
part.
ORIGIN 8.19 -6.34 7.43
Defines the pivot of the respective part.
NONBBOX
Defines that the part cannot collide with 
other parts.
FROM Head 0.0.0
Defines the space and connection 
between ORIGIN of a parent and child 
part.
AXES X Y Z
Defines 3 axes of rotation. With a minus 
sign in front of the axis you can define 
the rotating direction (clockwise or 
counterclockwise)
RANGE 260,0 360,0 360,0
Defines limits for rotation of joints.
JOINT Hat
Defines name of the joint.
SRF bassb_cap
Defines the 3D object that will be used 
(SRF file).
PAINT cap.jpg
Uses an already existing texture (here 
'cap.jpg'). In this case, other than with 
the use of MMG files, you need to add 
the extension. Before you can create the 
outfit, you need to save the texture in 
c:\moove\Art\JPG (or in the respective 
installation folder). 

If you only use a texture (no MMG), the 
object cannot be colored in the Actor later on
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The MMG File
 

Basics
The MMG file is a file format created by moove.

Files in the MMG format enable the user to change certain areas of the texture: You can 
make it 100% transparent, 50% transparent and colorable, or only colorable. 

The MMG file consists of a texture (JPG) + a mask (4 Bit BMP); the mask determines how 
the texture is used. 

By using a 4 Bit BMP file with MMG, you have a color palette of 16 colors in total. However, 
the colors are only indirectly important for the representation of the outfit. The colors you 
chose for the 4 Bit BMP file do not mean that the base texture (here 'bassb_cap.jpg') is 
painted with these color or that you will only be able to color with these colors in the Actor 
Studio. The colors only represent a color index from 0 to 15 that moove Roomancer 
recognizes as information/code. 

For every color index value there's a special property. For example, the number 0 (Color: 
black) tells moove Roomancer that the black area of the 4 Bit BMP texture has to be 
displayed as 100% transparent over the base texture - i.e. nothing of the JPG texture is 
used. The number 3 has the property to show 50% transparency and be colorable as well. 
The numbers from 7 - 14 determine that the area has to be displayed as colorable. This 
also means that you can set 8 fields in the coloring panel of the Actor Studio as colorable, 
since 8 colors have this property. The number 15 (color: white) in the 4 Bit BMP 
determines that that for this pixel, the JPG base texture is used.

PLEASE NOTE: If you want to make the object colorable, you have to use the sequence of 
the color index. For example, if you only want to use a single color (by putting "MAXCOL 
1" in the ASM file), you need to paint the colorable areas of the 4 Bit BMP with the color 
index color 7. If you want to use two colors (by putting "MAXCOL 2" in the ASM File), you 
need to use color index colors 7 and 8. If you want to use three colors ("MAXCOL 3"), you 
need to use colors 7, 8, and 9, etc.

 



 
This is important if you want to create a pair of pants, for example, and want the buttons, 
the belt, the pants themselves, etc. to be colorable in the Actor Studio. If you want to 
color many different areas (e.g. many little circles that are spread out over the 4 Bit BMP 
mask), then you can use the same color on these circles (even if they aren't directly 
connected) and will have the possibility to color all circles with one click in the Actor 
Studio. 
The resolution of the 4 Bit BMP has to be exactly the same as the size of the JPG file, i.e. if 
the JPG file is 100x150 pixels, for example, the 4 Bit BMP needs to have the same size..

Use
In detail, what are the different possibilities for creating the object?

There's the possibilities to paint the object with a texture (here 'cap.jpg'). In our example, 
the texture looks like this:

Here is an overview of the color index with the respective colors:



So what should you do if you want to be able to change the colors of the object in the 
Actor Studio later on? As already mentioned, you need to use an MMG file. The MMG file 
consists of a base texture (here 'bassb_cap.jpg') and a 4 Bit BMP mask (here 
'bassb_cap.bmp'). The 4 Bit BMP mask can be edited in any graphics program, e.g. Paint 
(component of all Windows operating systems). After editing, our 4 Bit BMP mask looks 
like this:

In this example we use five different colorable areas. These areas can be painted with the 
help of the coloring panel in the Actor Studio later on. As you can see, our example does 
not have 50% or 100% transparent areas. By way of the following graphic we will 
demonstrate the composition of an MMG file. 

Of course you can also use the base texture (here 'bassb_cap.jpg'):



 

MMG Creation
To create an MMG file you need the 'mmg.exe'. You can find it in the "moove shop" -> 
"Developers". The 'mmg.exe' has to be saved in the moove Roomancer installation folder. 
Open the 'mmg.exe' and choose "File" -> "New" from the menu. You'll get to see the 
following window:
 

 
Under "Base File Name" you need to enter the complete path of where the base texture is 
located (i.e. the JPG file - in this case 'bassb_cap.jpg'). Under "Mask File" you need to 
enter the path to the BMP file (here 'bassb_cap.bmp'). Under "Output File" you need to 
enter the path where you want the MMG file to be created. This path always has to be 
'C:\moove\Art\MMG' (or the respective installation folder). To create the MMG file, click on 
the button "Create".



 

The Outfit file
The outfit file defines the type and look of the object in the Actor Studio. To create a new 
outfit file, you need to open moove Roomancer. Active the 'Test mode' under "View" -> 
"Options" -> "Service". 
Enter the following command:
Example I: Using the first ASM file (with MMG)
!ASMFileToOutfit("c:\\moove\\Actor 
Tutorial\\bassb_cap.asm","c:\\moove\\outfits\\Hats\\Baseball Cap (Colorable).outfit")
Example II: Using the second ASM file (with texture)
!ASMFileToOutfit("c:\\moove\\Actor 
Tutorial\\bassb_cap2.asm","c:\\moove\\outfits\\Hats\\Baseball Cap (Jeans).outfit")
The first path is the source of the ASM file you created. The second path is where you 
want the outfit file to be created and saved. Since our baseball cap is a hat, it should be 
created in the folder "Hats". (Important: Please create the respective folder if it doesn't 
exist yet. Otherwise the outfit file cannot be created.) Please don't forget to change the 
paths from our example accordingly. 
If everything was done correctly, you will see the message 'TRUE' in the chat window. If 
you should get to see 'FALSE', please check if all paths are entered correctly. (Please note 
double \\!) 

 

 

 
If everything was entered correctly and the outfit file was created, you can find and use it 
in the Actor Studio (Button "Actors" -> "Actor Studio").



Result...

 

 

using an mmg file

 

 

using a texture



Tutorial For Creating Carpets And Decorations In moove online

"Roomancer" moove online provides a terrific tool called DecoMaker (requires DirectX 9 
 With the help of DecoMaker you can now easily create carpets and decorations 
yourself. DecoMaker can be found in the moove "Shop" --> "Developer" tab.

To create your own carpets and/or decoration, resources like 3D objects (.SRF) and textures 
(.JPG) are needed. You create them outside DecoMaker using a 3D software and your favourite 
paint program (not provided by moove). Of course it's easiest if you use existing moove SRF files. 
You find them in the corresponding moove/ART/SRF folder. You can freely use moove’s SRF files 

for your own creations within moove “Roomancer”. If you want to use SRF files provided by 3rd 
parties however, make sure to ask the respective author(s) for their permission before you start 

using them. 3rd party developers often start their file names with abbreviations so you can 
recognize them more easily (like for example em_…..srf , SQ_…..srf , MrZ…srf, MW_…srf, IR_…srf 
and so on, these files are not by moove).

●     Creating decoration, gadgets and carpets

●     Digital signature & creating MPZ

Decoration and carpets
In order to create decoration and carpets you need DecoMaker. This tool can be found in the 
moove "Shop" --> "Developer". Start DecoMaker by double clicking file "DecoMaker.exe" which 

should be placed in your moove Roomancer installation folder (usually c:\moove or c:\rose in 
case of long time users)..

At first please pick what you want to create: decoration or carpets. Click on "Mode" and then 
select"Carpet" or "Decoration".
 
Notes on creating decoration gadgets 
English Name
defines the english name of the decoration how it will appear in the english version of moove 
Roomancer. This field can’t be omitted.
German Name
defines the german name of the decoration how it will appear in the german version of moove 
Roomancer. This field is optional. Use a translation service. 

 if you want to include a german name as well or ask your german buddies.

Download URL
enables the automatic download from a web server. Here you can enter the URL where the MPZ 
file will be available for automatic download. If for instance a guest of yours doesn't have this 
particular decoration, it will be downloaded automatically.

http://www.microsoft.com/windows/directx


Surface
defines the 3D object (SRF/3DS/X - file) you want to use.
Orig. Vertices / Cur. Vertices
The surfaces are composed of three-dimensional room points - called Vertex. A high number of 
vertices signifies a detailed view, but a slower transmission and view. Hence DecoMaker allows to 
simplify a surface by reducing the number of vertices. Under "Cur. Vertices" please enter the 
wished number and click on "Do!". In the preview window you'll see the surface with the new 
number of vertices. "Orig. Vertices" reverts changes back to original values
Texture
defines the texture (JPG/BMP/TGA/DDS - file) you want to use for the object.
Stackable
defines, if the decoration is stackable and thus can be laid on another gadget. If this option is 
deactivated, these gadets will “behave” like carpets, meaning they always stay on the floor.
Cast Shadow
defines if the decoration should cast a shadow.
Climbable
defines if the actor can climb on the decoration
Ground Height
defines the distance to the ground. Utilizing this option you can produce gadgets, which appear to 
be attached to the walls (e.g. the "torch").
either:

Software + Hardware Renderer (The texture must be preshaded)
sets the decoration to be used with the software- as well as the hardware-renderer, but in fact it's 
optimized for the software renderer. This basically means that the shading must be "painted" in 
the textures. The best results can be achieved using "hand shaded" textures. Alternatively you 
can use the automatic shading (vide "Automatic Diffuse Shading Calculation").



Automatic Diffuse Shading Caculation
shades the texture automatically.
Tessellate for Shading Calculation
tries to better the quality of the shading.
or (recommended):

Optimized for Hardware Rendering
optimizes the decoration for usage with the hardware-renderer. No need to manually put shades 
in the textures. Additionally you can select different "Shader", which affects the property of the 
material.
Shader
select special effects which will be applied to the textures. Not all shaders are currently supported 
and with some you might notice incorrect previews. Just test and play a bit with it :P
Width (X)
defines the width of the decoration.
Height (X)
defines the height of the decoration.
Depth (X)
defines the depth of the decoration.
  
Notes on creating carpets 
English Name
defines the english name of the carpet how it will appear in the english version of moove 
Roomancer. This field can’t be omitted.
German Name
defines the german name of the carpet how it will appear in the german version of moove 
Roomancer. This field is optional. Use a translation service such as Babelfish if you want to 

include a german name as well or simply ask your german buddies for help with a german name.



Download URL
enables the automatic download from a web server. Here you can enter the URL where the MPZ 
file will be available for automatic download. If for instance a guest of yours doesn't have this 
particular decoration, it will be downloaded automatically.
Surface
pick a surface from a list of predefined ones.
Orig. Vertices / Cur. Vertices
The surfaces are composed of three-dimensional room points - called Vertex. A high number of 
vertices signifies a detailed view, but a slower transmission and view. Hence DecoMaker allows to 
simplify a surface by reducing the number of vertices. Under "Cur. Vertices" please enter the 
wished number and click on "Do!". In the preview window you'll see the surface with the new 
number of vertices. "Orig. Vertices" reverts changes back to original values
Texture
defines the texture (JPG/BMP/TGA/DDS - file) you want to use.
either:

 

Software + Hardware Renderer (The texture must be preshaded)
sets the carpet to be used with the software- as well as the hardware-renderer, but in fact it's 
optimized for the software renderer. This basically means that the shading must be "painted" in 
the textures. The best results can be achieved using "hand shaded" textures. Alternatively you 
can use the automatic shading (vide "Automatic Diffuse Shading Calculation").
or (recommended):



Optimized for Hardware Rendering
optimizes the carpet for usage with the hardware-renderer. No need to manually put shades in 
the textures. Additionally you can select different "Shader", which affects the property of the 
material.
Shader
select special effects which will be applied to the textures. Not all shaders are currently supported 
and with some you might notice incorrect previews. Just test and play a bit with it :P.
Width (X)
defines the width of the carpet.
Height (X)
defines the height of the carpet.
Depth (X)
defines the depth of the carpet.

 
Digital signature & creating MPZ
To distribute your decorations / carpets to other moove online members, you can create MPZ 
files. MPZ format is self-installing, meaning by one click the file will be downloaded and installed 
automatically. The necessary files will be composed to packages and can be put on a website. The 
files are then available to other moove online members.
  
Digital signature 
You can sign your MPZ packages with a unique digital signature. The signature confirms that the 
developer is known to moove and consequently gives you a guarantee that this package is 
provided by a certain member. To get a digital signature, please contact support@moove.com via 

email.



  

The digital signature can be entered and saved under "File" --> "Set Authorization". Under "Key 
File" enter the specific path to your digital signature (*.private file, for example 
c:\moove\MySig.private). Under "Author" you enter your nickname (Premium members please 
note: enter without **) and under "Author's Info URL" you finally enter the URL to your nickpage 
or website.
  
Creating MPZ
Click on "Create MPZ" to create a MPZ file. Choose a file name and click on "Save".

Important Notice: If you entered a URL under "Download URL", the file name DecoMaker 
generates must not be changed! Otherwise the automated download of the MPZ file will fail and 
the decorations / carpets won't be displayed.

 

 



Tutorial For Packing Outfit Files With The moovePack Tool
The moovePack tool allows you to easily offer your self-made actors, furniture, outfits, and 
decorations to other members.
This tool automatically packs all necessary files into an MPZ package, which can be easily 
embedded into your website. Your site's visitors will be able to download and install this 
file with just one click.
Please read the general notices and instructions for packing other files with the moovePack 

tool

Tip:
Please also have a look at our extensive tutorials on the creation of outfits, decorations 
and styles 

Example: How do I create an MPZ file (using an outfit file 
[*.outfit])? 
You created your own outfits with help of the tutorial for creating your own outfit files for 
the Actor Studio, and now you want to offer these outfits for download on your site? 
Please do the following:

Step 1:
Open the moovePack tool (which you can find in your Roomancer installation folder) and 
then click on the "Outfits" button.

 

Step 2: 
In this window you can see two entry fields, one for the path/file name of the outfit 
(*.outfit) and the other one for the path/file name of the actors (*.actor) that were 
created with the Actor Studio. Since we only have one outfit file with the name "Cords 
(Ladies).outfit", enter the name of the subfolder of the folder "Outfits" from your moove 



Roomancer installation folder and the necessary file name. 
If you want to pack more than one outfit into an MPZ, please separate the entries in this 
field by ; (semicolon). Finally, click on "OK".

 

Step 3:
Now click on "Create Package" or on "File -> Create Pack" to create an MPZ file.

 

Step 4:
Now you will have to enter a name for your file and decide where you want to save it.

 

You have now created an MPZ file! :)



moovePack tool

You can add a digital signature to any MPZ file. The signature confirms the developer and 
guarantees to some extent that this package was created by a member and that the PC of 
other members won't be affected negatively. To get a digital signature, please contact 

support@moove.com

.

  

The digital signature can be entered and saved under "Edit -> Set Authorization". 
Under "Key File", you need to enter the exact path to your digital signature (*.private file). 
Under "Author", you enter your nickname (premium members, please note: don't enter 
**), and under "Author's Info URL" you can enter the URL to your nickpage or website. 

You have your own website and don't know how to change your 
HTML code to be able to offer your MPZ files for download? 

You can find a detailed informations here.

  

Adding digital signatures to your MPZ packages with the 



General Notices And Instructions For Packing Other Files With The 

moovePack Tool.

 

●     SETUP: copy moovepack.exe and your key (vel.private) to a folder of your 

choice. Start moovepack.exe and go to top menu "Edit" -> "set authorization". 

Put the path+name of the key file in field "Key File", for example: 

"c:\rose\vel.private". Put "vel" as author (no other entry is valid here). The URL 

you can freely pick yourself, you could put your rose profile page or your 

homepage there if you like or any other URL of your choice. You will now be 

able to create packages, which are digitally signed with your name. You should 

not pass on your unique key to others of course.

 

●     USAGE: A package is created by going to top menu "File" -> "Create Pack". The 

package name needs to end in extension .MPZ.

To be able to modify a package at a later time you should save the "project" via 

"File" menu -> "save" or "save as..", best

pick an extension like .MP (not MPZ, that you should only use for create pack!) 

when chosing a file name to save

 

●     INCLUDE FILES: just drag & drop UNI Files, SRFs, JPGs/BMPs, Sounds etc. you 
want to be included in your package from Windows onto the open moovepack 
program.

 

●     ROOMS: if you would like to create a package of a pre-decorated room for 

example, you should first start Roomancer and make a backup of that room via 

the "File" menu in Roomancer. (*ATTENTION MOOVE ONLINE ROOMANCER 

USERS* If you do the backup while being in "mature mode" (moove online 

Roomancer), the room will only be available to moove online Roomancer users 

in mature mode, regardless of you checking the "for mature users" box in 

moovepack or not. So, if you would like your room package to be available for 

rose life members as well, you need to first log in using Roomancer without the 

"mature mode", create your room and then do the backup while still being in 

non-mature mode). You will find the backup of the room in a subfolder of 

rose\backup\, if you make a backup of the kitchen for example, you will find file 



"Kitchen.Roombackup" in folder rose\backup\MediumRoom_West\ (because the 

kitchen is based on MediumRoom_West). If you would like to create a package 

of the kitchen, you would now use moovepack to locate file 

"Kitchen.Roombackup" by clicking on the "Browse" button besides field "Backup 

File". Last not least put the name of the room ("Kitchen" in this example) in field 

"Room Name". You will not have to check box "Include ROM file" unless you 

built this room on a ROM file that was not installed by moove, but by a 3rd 

party.

 

●     FURNITURE: to create a furniture package, drag & drop the UNI file as well as 

SRFs & JPGs/BMPS from Windows onto moovepack. Then click on the 

"Furniture" button. On the next screen click "New" button, then pick the kind of 

furniture you are putting in the package: Furniture, Gadget or Door. Put the 

name of the DOORS furniture function of your UNI file (NOT the name of the 

UNI file!) in field "Internal Name", the measurements under X/Y/Z coordinates 

and finally the english and german name (if you don't know or care about the 

german name, just put the english name in both fields). You can add more than 

just one piece of furniture here of course.

 

●     SHOWCASES: clicking the "Showcases.." button you can add files of your own 

that are located in subfolders of rose\ShowCases\... , like for example new 

postures, expressions, actions etc. You could for example put an expression you 

created yourself called "grinning" into the package by adding this line to the 

expression field: 

- "grinning.thumb;grinning.post". Make sure that those 2 files do exist in folder 

rose\ShowCases\Expressions (and not a subfolder of it) so that they can be 

found. 

- The user that installs your package however, will find your expressions in 

subfolder rose\ShowCases\Expressions\vel\ which can be accessed via the Show 

button -> Expressions -> vel in Roomancer. You can proceed the same way with 

other ShowCases like postures, actions, games you created. If you want to 

package tools you wrote, put them in ShowCases\Tools\ when creating your 

package. The user will find them under Show button -> NonMooveTools in 

Roomancer.



 

●     HTML: enter HTML files using the HTML button, HTML files might be needed for 

games you designed for  on Javascript basis (like moove's Poker Game).

 

●     OUTFITS: enter self-created .outfit files for the actor studio using the OUTFITS 

button. JPG, BMP, SRF, ASM & MMG files do =not= need to be packaged.

 



Introduction 

It is very easy to convert old actor files into actor files of the new generation. To do this, you 
need to put the template definitions from the UNI files and the surface and texture definitions 
from the TXT files into a single file: the ASM file
 



  

Instructions
 ASM File - New Actor 
Generation
 

"Old" Rose Actor Template and TXT 
File
 

http://web.moove.com/mpz/actors/Bodies.zip


Now you have created an outfit file from your rose actor. If you follow the above 
example, this file will be saved in the folder moove\outfits.
To be able to use this outfit as an actor, open the Actor Studio and "wear" your "actor 
outfit". Then click on "Save", give a name to the converted actor and click on "OK" - just 
like you always did when you saved a dressed up actor from the Actor Studio. Your new 
"actor outfit" will be saved as an .actor file in moove\Actors. Your new - old :) - actor will 
now appear in moove Roomancer under "Actors" -> "My Actors" - ready for use!
Of course you can also offer your converted actor for download on your website. Just 
pack it with the moovePack tool so it can be downloaded and installed automatically. Your 
visitors will thank you. :)

In the following we will illustrate the differences between the old rose actors and the actors of 

the new generation, and how you can adapt them. 

 

 

4. "Muscle" are morph targets (heads only) for the expressions.
Only enter these when they exist. (They don't exist in the old templates.)

5. If your template should miss the lines shown next to number 5 in the example graphic 
above, don't worry. :)
Enter the missing line, namely "Axes X Y Z", into the ASM file at the right place. If you 
already defined all body parts in the ASM file, put the following into the chat line: 
"!AsmFileToOutfit(<.asm file>, <.outfit file>)"
Instead of <.asm file> insert the exact path to your already existing ASM file. Please note 
that the single backslash (\) has to be replaced by a double backslash (\\).
For <.outfit file> enter the exact path where you want the final outfit file to be created.
Here is an example for this:
!AsmFileToOutfit("c:\\actor\\myactor.asm", 
"c:\\moove\\outfit\\myactor.outfit")

 

1. Creating The ASM File
Use the text editor to create a new file with the extension "ASM" (example: 
myactor.asm). Copy the first line directly from the example (Level 0, Maxcol 0). Single 
body parts are defined as shown above. Sizes and other parameters can be found in the 
template description (2.) and the TXT file (3.).
Hint: If you want your actors to be able to wear Actor Studio outfits, you should use the 
same names, or even better yet, the same dimensions. You can use the example actors 
in the shop (bodies.zip) as a base.

2. Template
To get a template of your actor, you need to do the following:
Choose your actor from "Actor -> Others". Now you need to activate the test mode under 
"Extras" -> "Options" -> "Service". Type "!ActorTemplateToClipboard()" into the chat 
line. Open a text editor (e.g. Notepad) and paste the clipboard content (File -> Paste). 
Now you have a template with all body parts and joints. Please transfer the relevant 
values into your ASM file, as shown in the exmample. In the file "bodies.zip", to be 
downloaded from http://web.moove.com/mpz/actors/Bodies.zip you can find some 

examples for complete actors (female.asm, male.asm, etc.).
3. TXT File

Here you can see a TXT file. In this file a SRF file (3D object) and texture is assigned to 
each body part.
Syntax:
Part: SRF, Texture
Enter the names of the respective elements into the ASM file. 



In the following we will illustrate the differences between the old rose 
actors and the actors of the new generation, and how you can adapt them.
 
 

Using "Mark" as an example - representing the old rose actors - we will show you how to 

convert an old rose actor into an actor of the new generation - in this case "female".  

 
For this we have created a couple of example files.
To prepare "Mark" we need to create an ASM file that contains all information about this actor. This 
means we need the template information and the surface and texture information from the TXT file - as 
described above. In fact you could say we're creating a whole body costume called "Mark". 
On the other side, we will put one of our female actors ("female").
Before you start, please download a file called "Mark.zip" from out server. "Mark.zip" contains all files 

needed for our example. If you compare the "female ASM" to the Mark's template, you will notice that 
the female actor has more body parts than Mark.
See below.

 

 
 

http://web.moove.com/mark.zip


 
 

To modify Mark for being available for use in the Actor Studio, Mark needs just as many body parts as 
shown in the "female" ASM file. Please have a closer look at the files "mark.asm" and "mark-
template.txt".

The body parts missing in "mark-template.txt" were added to the "mark.asm" and reduced in size. 
The "joint.srf" (to be found in your SRF folder) additionally causes all parts not relevant to "Mark" to 
become invisible.
However, we kept the structure (joints) of "mark-template.txt" in "mark.asm". 
Below, in "markbetter.asm", we show the better solution. Compare "mark.asm" to "markbetter.asm", in 
particular the parts Head, Neck, _RighJoint, _LeftJoin, RightUprarm and LeftUprarm.



 
 
Now put the following in the chat line:
!ASMFileToOutfit("c:\\<path to your asm>\\mark.asm", c:\\<path to 
Roomancer\Outfits>\\mark.outfit")
Now select the "female" actor and enter the Actor Studio.
In the Actor Studio you select the piece of clothing "Mark" and "wear" it.
If you want your actor to appear male (after all we based it on a female actor), give it a new soul. You 
can do this by clicking on "Advanced" and then choosing a soul, e.g. "adv_male").
Now you only need to save and you're ready!

Important:
Before you convert the actor for the Actor Studio, please make sure that all "SRF" and "JPG" are 
available in the relevant folders. 

 

  



Tutorial For The Creation Of Styles

First of all, you need the stylecomp.exe and some .bmp and .txt samples. You can 
download these in the moove shop -> Developers. Please save the files in a folder of 
your choice on your PC.

The stylecomp.exe is a tool that creates a style for moove Roomancer. More information 
about this can be found towards the end of this tutorial.

First, however, you need to realise your ideas for a great style in a picture editing 
program of your choice. For this, you need the following samples that can be found in the 
.zip file you downloaded:

●     maske.bmp 

●     maske_toolbarbuttons.bmp

●     maske_item.bmp

●     menu.bmp

●     Color.txt

●     Font.txt

●     Metrics.txt

●     Setting.txt

●     band.avi

●     lamp.avi



 
The upper graphic shows the mask, which can be changed in a picture editing program, 
and the resulting style "Ellipse".

 

maske.bmp
In the following you will find a step-by-step tutorial on how to do this. Please click on 
the separate picture elements in the graphic below to see an explanation.
Good luck with creating your style!
 

 

 

maske_toolbarbuttons.bmp:
Here you can define the buttons in the toolbar menu. Please disregard the white and gray 
fields in this case.
The middle line displays the active buttons; the one at the bottom shows pressed buttons.
  

file:///C|/WEB_Ordner/help_advanced/mentalmessage.htm
file:///C|/WEB_Ordner/help_advanced/buttons.htm
file:///C|/WEB_Ordner/help_advanced/beenden.htm
file:///C|/WEB_Ordner/help_advanced/schieberegler.htm
file:///C|/WEB_Ordner/help_advanced/raum.htm
file:///C|/WEB_Ordner/help_advanced/chat.htm
file:///C|/WEB_Ordner/help_advanced/2d3d.htm
file:///C|/WEB_Ordner/help_advanced/2d3d.htm
file:///C|/WEB_Ordner/help_advanced/popup.htm
file:///C|/WEB_Ordner/help_advanced/popup.htm
file:///C|/WEB_Ordner/help_advanced/rand.htm
file:///C|/WEB_Ordner/help_advanced/hptmenu.htm


 

maske_item.bmp:
This shows you a folder with your last used actors in the Actor Studio. To the left you can 
see the mask that can be changed and to the right the finished and implemented graphic 
in moove online.
 

 
  

 
  

 

menu.bmp:
Should keep the preset color [rgb(255,0,255)] and should not be changed.
 

Now you can open each file separately, change it to whatever you want, and save it as a 
.bmp file. If your framework looks like you wanted it to, you will now need the .txt files.
 

 



 

Color.txt: Color.txt: Here you can 
change the colors, for example the 
font color in the menu, ... These 
colors are in rgb.

for 1.: default background color 
for 2.: font color of the individual 
buttons in the pop up windows (Actor 
-> My Actors -> female)
for 3.: titles of the pop windows 
(Actor -> My Actors), but also the 
text of the main menu (File, Edit, ... 
and "*...* is at home")
for 4.: does not have to be edited
for 5.: does not have to be edited
for 6.: text of the toolbar menus 
"Back, Community, House, ..."
for 7.: small arrows that appear 
when you minimize the browser
for 8.: background of the dialog box -
> Rotate -----I-----, Zoom -----I-----
for 9.: "You say:" 
for 10.: border of the choice of color 
in the Actor Studio and Posture Editor 
- shading point
for 11.: border of the choice of color 
in the Actor Studio and Posture Editor 
- lighting point
for 12.: text on buttons (e.g. 
camera)
for 13.: default color for 
transparency
for 14.: text entry background
for 15.: text
for 16.:background of the pop up 
window "House -> My House"
for 17.: font color in the pop up 
window "My House"
for 18.: owner name in room 
("House -> My House")
for 19.: visitor name in room 
("House -> My House")
for 20.: does not have to be edited
for 21.: does not have to be edited
for 22.: does not have to be edited
for 23.: does not have to be edited

Color.txt:
 



for 24.: does not have to be edited
for 25.: does not have to be edited
for 26.: background of the pop up 
menus ("Actors -> My Actors, ...")
for 27.: font color of the sub-points 
of the pop up menus ("My Actors")
for 28.: background of the sub-
points of the pop up menus ("Actors -
> My Actors, ...") - onmouseover
for 29.: font color of the sub-points 
of the pop up menus ("My Actors") - 
onmouseover
for 30.: does not have to be edited 
for 31.: does not have to be edited
for 32.: does not have to be edited
for 33.: does not have to be edited
for 34.: does not have to be edited
for 35.: does not have to be edited
for 36.: borders of the sub-points in 
the pop up windows - lighting points
for 37.: borders of the sub-points in 
the pop up windows - shading points
for 38.: borders of the sub-points in 
the pop up windows - onmouseover
for 39.: does not have to be edited
for 40.: font color in the pop up main 
menu (File, Edit, ...)
for 41.: bar behind the text in the 
pop up main menu - onmouseover 
(File, Edit, ...)
for 42.: font color in the pop up main 
menu - onmouseover (File, Edit, ...)
for 43.: inactive text in the pop up 
main menu (File, Edit, ...)
for 44.: borders of the pop up main 
menu (shading points) (Actors -> My 
Actors, ...)
for 45.: borders of the pop up main 
menu (lighting point) (Actors -> My 
Actors, ...)
for 46.: main menu "onmouseover 
border" below and to the right (File, 
Edit, ... Help)
for 47.: main menu "onmouseover 
border" above and to the left (File, 
Edit, ... Help)



for 48.: does not have to be edited
for 49.: does not have to be edited
for50.: does not have to be edited
for 51.: does not have to be edited
for 52.: does not have to be edited
for 53.: does not have to be edited
for 54.: does not have to be edited
 

 

font.txt:
 

Here you enter the individual fonts 
and font sizes. The font sizes are 
optimized so that they don't have to 
be changed. The font can be changed 
any way you like.



Metrics.txt: Here you can change the 
distance between the different elements in 
the moove online browser. However you 
don't have to change this file, since the 
defaults are optimized.
The only settings that might require 
changing are the following:

for 1.: _ button -> distance to border
for 2.: o button -> distance to border
for 3.: x button -> distance to border

Usually you have to adjust these to your 
style. 

 

 

 

metrics.txt:
 



 

Here you can set the properties of the 
individual backgrounds. Backgrounds 
can be tiled ("0") or masked ("1").
This file doesn't have to be edited.

 

band.avi: 
This file doesn't have to be edited.
 

 

lamp.avi: 
This avi displays the animation to the top right of the browser. It has to be created with a 
program that supports .avi files. The size should be 50x21 pixel and the file cannot be 
compressed. You can safely ignore band.avi, since it doesn't have to be changed.
 

 

 

As soon as you have edited your files, 
please open the stylecomp.exe. Click 
on "..." and open the files you edited 
(maske.bmp, 
maske_toolbarbuttons.bmp, 
maske_item.bmp, menu.bmp, 
colors.txt, metrics.txt, ...).
Now click on "Write Style File" and 
save the style in the "STY" folder in 
the "Art" directory of your moove 
online folder.

settings.txt:



Go back to your moove online main 
directory and open the "Styles" 
folder, to be found in the 
"Showcases" folder. Here you can 
find the .uni files for the already 
existing styles. Copy one and rename 
it. Then open it and put the name of 
your style into the brackets and the 
quotes.

Now you can find your style in moove 
online under Extras -> Styles. If you 
don't like something about your style, 
you can work on it again, save it, and 
compile it again with the 
stylecompiler.

  
  
Tip:
To get a feeling what your finished style will look like in moove online, you can already 
compile your style with the stylecompiler after only a few changes to the .bmp files and 
check it in the moove online browser.

 

 



Tutorial for the creation of screenshots

■     Press the "Print" key on your keyboard.
■     The current screen will be saved to the clipboard.

 

■     Open a picture editor of your choice.
■     If you do not have a picture editor, you can open Microsoft Paint via Windows 

"Start" > Programs > Accessories.

 



●     Paste the screenshot via "Edit" > "Paste".

 

●       Save the screenshot via "File" > "Save As..." in a folder of your choice. 



Level overview 

  

BODY 0

HAIR 500

HAT 600

SOCKS 1000

SHOES 2000

PANTS 3000

SHIRTS 4000

JACKETS 5000

 

 



HTML sourcecode for MPZ files
Copy the code from the following table and add it to your HTML file. Of course you need to 
complete it with your part of the source code, for example by adding more text and 
pictures - just like you usually create websites. After that you change the name of the 
picture and the path that points to the MPZ file: 

<HTML>
<HEAD>
<TITLE></TITLE>

<SCRIPT LANGUAGE="JavaScript">

confirmText="The chosen item can only be\n"
                 +"installed with moove Roomancer.\n\n"
                 +"Do you wish to start up moove Roomancer?"

function InstallMPZ(sMPZ)
{
        var bInstall;

        if(RoseCommand21.IsBrowserOnAdvanced() != 0) // Roomancer running?
                bInstall = true;
        else
                bInstall = window.confirm(confirmText);

        if(bInstall)
                RoseCommand21.ExecuteAdvanced(99999, sMPZ, 10000); // nID, sParam, 
nTimeOut
}

</SCRIPT>

</HEAD>

<BODY>

<OBJECT id=RoseCommand21 classid=clsid:EF8A8A22-EF05-4C7D-BC34-9BBF1DBC86F1 
VIEWASTEXT >
</OBJECT>
<IMG src="example.jpg" onclick=InstallMPZ("mpz/example.mpz")>

</BODY>

</HTML>



The line (img tag) where you change the file name (picture) and the path to the MPZ file 
can of course be used as often as you want if you are offering more than one MPZ file for 
download.
As in the moove shop, clicking on the preview picture will start the download and 
automatic installation of the MPZ file. 
If you have any questions and/or problems, feel free to contact support@moove.com 

Please note: 
Please also have a look at our notes about creating decorations and styles, so that those 
can be downloaded and installed automatically as well. 
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